U3D Export
#1
Hallo Community,

ich suche schon ein Weilchen nach ein Möglichkeit, ein Modell als .U3D zu exportieren, damit ich es später mit LaTeX weiterverarbeiten kann.

Bitte kein SketchUpToPDF-Exporter, der bringt mir nichts, brauch direkt die U3D-Datei!

Danke und Mfg,
Tropaion
Antworten Zitieren
#2
Plugin gibt's m.W. nach keins, alternativ in ein 3D-Polygonnetz-Format (OBJ, 3DS, Collada DAE) exportieren und mit dem freien MeshLab in das Universal 3D U3D-Format konvertieren.

Norbert
Antworten Zitieren
#3

.pdf   ControlCircuit1.pdf (Größe: 97,54 KB / Downloads: 8) Habe ich schon versucht, aber er überträgt mir die Texturen nicht und das Model wird teilweise fehlerhaft angezeigt -> siehe Stecker. Aber das hatte ich schon öfter, weist du woran das liegen kann?

Hier funktioniert es: https://skfb.ly/IqqJ


Angehängte Dateien
.skp   ControlCircuit.skp (Größe: 3,9 MB / Downloads: 3)
Antworten Zitieren
#4
Ich habe erfolgreich diese Vorgehensweise verwendet (nur ohne Texturen!): http://www.cadforum.cz/cadforum_en/creat...re-tip9972

Die Steckerprobleme könnten auf eine falsche Flächenausrichtung hinweisen, hast du die Flächennormlaen vor dem Export kontrolliert?

Ist das Ziel die Erstellung der 3D-PDF und wenn ja, warum ist ein 3D-PDF-Exporter dann ausgeschlossen?
Antworten Zitieren
#5
Ja, das Ziel ist eine 3D-PDF. Aber ich schreibe meine Dokumentation immer mit LaTeX und möchte die bequem mitten im Text einbinden können. Zudem bietet LaTeX einfach sehr viele Einstellungsmöglichkeiten.

Wie kann ich die Flächenausrichtung kontrollieren? Ich bin noch relativ neu in dem Bereich (seit ein paar Tagen).
Was ich vor dem exportieren immer machte, ist das ich CleanUp verwende.

Vielen Dank und Mfg,
Tropaion
Antworten Zitieren
#6
Flächenstil Monochrom hilft hier weiter...

   
Antworten Zitieren
#7
(06.11.2015 - 21:06)Tropaion schrieb: ...aber er überträgt mir die Texturen nicht...

für eine Datenübertragung von Materialien/Texturen das 3DS-Format verwenden und bei den "Optionen..." in der Sektion "Materialien" die Option "Texturzuordnungen exportieren" aktivieren.

Norbert
Antworten Zitieren
#8
Ja und was hat das mit meinem Problem zu tun?

Bei SketchUp funktioniert eh alles. Es ging bei denn Texturen um das konvertieren mit MeshLab später dann.
Außerdem unterstützt MeshLab das 3DS-Format nicht.

Mfg,
Tropaion
Antworten Zitieren
#9
Hat die Änderung der Flächenausrichtung etwas bezüglich der fehlenden Flächen gebracht?
Antworten Zitieren
#10
(09.11.2015 - 16:39)Tropaion schrieb: Ja und was hat das mit meinem Problem zu tun?

(06.11.2015 - 21:06)Tropaion schrieb: ...aber er überträgt mir die Texturen nicht...

keine Materialien/Texturen im OBJ-Format.

(09.11.2015 - 16:39)Tropaion schrieb: Außerdem unterstützt MeshLab das 3DS-Format nicht.

selbstverständlich unterstützt MeshLab das 3DS-Format.

Norbert
Antworten Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste