STL Im-/Export in SketchUp Make
#1
Moin !

Sollte das STL-Plugin (direkt von der SketchUp-Seite) in SketchUp Make "funktionieren" (installierbar sein) ?

Oder

Wie sonst kann ich STL-Dateien im-/exportieren ?

Bis die Tage

Frank
Antworten Zitieren
#2
Sollte funktionieren, entweder direkt in SU per "Fenster > Erweiterungsmarkt" oder per Download der RBZ-Datei (RuByZipped) aus dem Erweiterungsmarkt (Google Konto notwendig) und Installation per:

• Fenster
• Voreinstellungen
• Erweiterungen
• Erweiterungen installieren...

Norbert
Antworten Zitieren
#3
Moin Norbert !

Besten Dank für Deine Hilfe !

Über Fenster>Voreinstellungen>Erweiterungen>Erweiterung installieren>Datei sketchup-stl-2.0.3_1.rbz ausgewählt

Dann kommt ein "Fenster"
<Diese Erweiterung kann auf das Dateisystem Ihres Computers zugreifen ..... Möchten Sie die Erweiterung installieren? >
mit ja bestätigt.

Dann kommt ein "Fenster"
<Möchten Sie zulassen das durch das folgende Programm Änderungen an diesem Computer zugelassen werden>
mit ja bestätigt.

Dann kommt ein "Fenster"
<Die Installation der Erweiterung ist abgeschlossen>
mit OK bestätigt.

Trotzdem ist unter den "Erweiterungen" die STL-Erweiterung NICHT an/aufgeführt (ich kann auch NICHT in STL im/exportieren).

Was mache ich falsch (lieg's an Windows 8.1) ? - bis die Tage

Frank
Antworten Zitieren
#4
Möglicherweise fehlende Benutzerrechte, starte die SU Setup-Routine mal per "Rechtsklick > Ausführen als Administrator" und führe dann die Installation aus.

Norbert
Antworten Zitieren
#5
Moin Norbert !

(17.02.2014 - 14:02)SketchUp schrieb: Möglicherweise fehlende Benutzerrechte, starte die SU Setup-Routine mal per "Rechtsklick > Ausführen als Administrator" und führe dann die Installation aus.

Das war's - Installation hat so geklappt (peinlich).

Aber

Ich kann immer noch KEINE STL-Datei im/exportieren.

Bei'm Export kann ich zwar nach dem aufrufen der STL-Export-Optionen (Einheit mm - Format ASCII) den Speicherort auswählen (die Datei wird auch im Dateinamen mit dem Zusatz >.stl< "eingesetzt") allerdings befindet sich im "Dateityp-Feld" KEINE Bezeichnung (ist völlig leer). und nach dem "drücken" des "Speichern-Knopfes" passiert NICHTS (Datei wird nicht gespeichert).

Bei'm Import kann ich zwar *.stl Dateien auswählen nach dem "drücken" des "Öffnen-Knopfs" passiert allerdings NICHTS (Datei wird nicht importiert).

Woran liegt's ?

Bis die Tage

Frank
Antworten Zitieren
#6
(18.02.2014 - 17:23)Rüster schrieb: Bei'm Export kann ich zwar nach dem aufrufen der STL-Export-Optionen (Einheit mm - Format ASCII) den Speicherort auswählen (die Datei wird auch im Dateinamen mit dem Zusatz >.stl< "eingesetzt") allerdings befindet sich im "Dateityp-Feld" KEINE Bezeichnung (ist völlig leer). und nach dem "drücken" des "Speichern-Knopfes" passiert NICHTS (Datei wird nicht gespeichert).

Das Dateityp-Feld ist standardmässig leer da hier nicht der normale SU Export-Dialog verwendet wird und somit ja klar ist, dass das STL-Format exportiert werden soll.

Um Probleme mit einem Modell auszuschliessen, lege ein neues Dokument an und erzeuge da irgendeine Kleinigkeit.

Um Probleme mit den Benutzerrechten im Speicherort auszuschliessen, speichere auf der lokalen Platte und nicht auf einer Netzwerkfreigabe.

Um Probleme mit Sonderzeichen wie z.B. Umlauten (z.B. aus deinem 'Rüster') im Speicherpfad auszuschliessen, speichere nicht in einem Benutzerverzeichnis wie z.B. dem Schreibtisch/Desktop sondern direkt im 'Root' der lokalen Platte, d.h. direkt unter "C:\".

Nach einem erfolgreichen STL-Export wird ein entsprechender Dialog mit den exportierten Elementtypen angezeigt.

Norbert
Antworten Zitieren
#7
Hallo Norbert !

Zitat:Das Dateityp-Feld ist standardmässig leer da hier nicht der normale SU Export-Dialog verwendet wird .....

Gut.

Zitat:Um Probleme mit einem Modell auszuschliessen, lege ein neues Dokument an .....

Habe ich getan.

Zitat:Um Probleme mit den Benutzerrechten im Speicherort auszuschliessen, speichere auf der lokalen Platte und nicht auf einer Netzwerkfreigabe.

Habe ich getan.

Zitat:Um Probleme mit Sonderzeichen ..... im Speicherpfad auszuschliessen, speichere nicht in einem Benutzerverzeichnis ..... sondern direkt im 'Root' der lokalen Platte .....

Habe ich getan.

Trotzdem - nach dem "drücken" des "Speichern-Knopfes" passiert NICHTS (Datei wird nicht gespeichert).

Bis die Tage

Frank

PS.: ich habe auch schon das Programm deinstalliert und NEU installiert (mehrfach) an/in verschiedenen "Orten".
Antworten Zitieren
#8
Starte testweise auch mal SU selbst per "Rechtsklick > Ausführen als Administrator".

Wenn das auch nicht hilft, SU beenden und bis auf "sketchup-stl.rb" und "\Plugins\sketchup-stl\" alle weiteren Plugins inklu. Ordnern aus dem o.g. SU Plugins-Unterverzeichnis rausschieben.

Norbert
Antworten Zitieren
#9
Halo zusammen,

ich habe gerade ein Beispiel dazu selbst versucht, funktioniert, STL-Datei wird automatisch erzeugt.

Bei der Auswahl habe ich ASCII wie vorgegeben stehen lassen. Testen kann ich die STL leider noch nicht.

Win7 und SU-2014 als Admin gestartet.

H.

vergessen: Der STL-Export steht niht in der Liste der Erweiterungen, sondern nur als selbständiger Menue-Punkt in <Datei> zusätzlich zu <Import> / <Export>
Antworten Zitieren
#10
für eine Kontrolle von STL-Daten kann das freie netfabb Studio Basic oder das schmale EasyViewSTL verwendet wrden.

Mehr Infos zum Thema 3D-Druck mit SketchUp haben wir auf der SketchUp Pro Website in einem diesbezüglichen Artikel beschrieben.

Norbert
Antworten Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste