Fehlerhafte Darstellung --> Objekte "geschnitten"
#1
Hallo zusammen,

beim Arbeiten mit SketchUp kommt es bei mir immer mal wieder zu einer fehlerhaften Darstellung, meine Objekte werden dann teilweise wie "geschnitten" dargestellt und ich muss erst wieder ein wenig herumzoomen und -drehen, bis alles wieder heil ist. Ist das

- auf irgendwelche 3D-Probleme meiner Grafikkarte zurückzuführen?
- auf irgendwelche falschen Einstellungen ("Betrachterabstand" o.ä. irgendwo falsch (zu kurz) eingestellt)?
- oder ist das einfach so hinzunehmen und passiert bei Euch auch?

Ein Screenshot ist angehängt.

Danke und Viele Grüße,
Sören


Angehängte Dateien Thumbnail(s)
   
Antworten Zitieren
#2
es handelt sich hier um das s.g. 'Clipping' (OpenGL) zwecks beschleunigter 3D-Bildschirmdarstellung durch Ausblenden nicht sichtbarer Geometrien vor und hinter dem sichtbaren Bereich ('Clipping Planes'):

[Bild: 700px-Cube_clipping.svg.png]
der Effekt kann durch verschiedene Einstellungen beeinflusst werden:

• "Kamera > Blickfeld" auf den Standardwert 35° zurücksetzen
• bei "Kamera > Parallele Projektion" sollte ein "Kamera > Alles zeigen" das Problem beheben, alternativ auf "Kamera > Perspektive" umschalten
• sehr kleine/grosse Modelle fördern den Effekt => gegenläufig grösser/kleiner skalieren
• Modelle (oder Gruppen/Komponenten) sehr weit vom Ursprung bzw. Nullpunkt des Koordinaten-Systems entfernt (z.B. nach DXF/DWG Import) fördern den Effekt (ggf. in DXF/DWG Import-Optionen abschalten) => komplette Geometrie einblenden* und zum Ursprung verschieben

*dazu:
- alle Layer einblenden
- "Bearbeiten > Einblenden > Alle"

Norbert
Antworten Zitieren
#3
Junge, Junge, das nenn ich mal eine fundierte Antwort Big Grin "Lustigerweise" trat das Problem bislang erst einmal nicht mehr auf, für den Fall habe ich ja aber jetzt eine Menge an Lösungen. Danke dafür!
Antworten Zitieren
#4
Hallo zusammen,
ich bin neu im Forum und nutz SketchUp seit einiger Zeit für kleinere private Projekte. Als alter Maschinebauer habe ich mittlerweile nur noch verblasste Erfahrungen mit anderen CAD-Anwendungen. Nach anfänglicher Skepsis arbeite ich nun aber gerne mit SketchUp, weil es so intuitiv bedienbar ist.

Das eingangs beschriebene Problem habe ich ebenfalls. Wie unter Punkt 4 beschrieben, ist der Nullpunkt meins Modells durch einige der genannten Aktionen sicher sehr weit vom Ursprung entfernt.
Nur, wie finde ich den "ursprünglichen" Ursprung? Oder wo finde ich die Aktion "zum Ursprung" verschieben?
Im Voraus vielen Dank
Markus
Antworten Zitieren
#5
Hallo Markus,

um die Achsen auf den echten Nullpunkt zurück zu setzen, machst du einen Rechtsklick auf eine Achse und wählst "Zurücksetzen".

Dann machst du erst mal alles, was im Modell drin ist, sichtbar. Also alle Layer auf sichtbar (Fenster > Standardablage > Layer) und die ausgeblendete Geometrie (Ansicht > Ausgebl. Geometrie) sichtbar.

Dann wählst du alles aus (Bearbeiten > Alles auswählen) und verschiebst dann alles mit dem Verschieben-Werkzeug zum Nullpunkt.
Antworten Zitieren
#6
(28.01.2018 - 17:30)Jörg schrieb: ... Dann machst du erst mal alles, was im Modell drin ist, sichtbar ...

https://extensions.sketchup.com/extensio...p-parallel 
- ist eine Alternative, wenn der Fehler doch nicht sichtbar wird.
Auch manch anderer der ehrenwerten Ratschläge zu den vielen Anfragen, wie mit Clipping umgegangen werden kann, ist bei sehr komplexen Modellen fragwürdig. 
Falls also noch niemand auf das Plugin hingewiesen haben sollte (hab's nicht überprüft) - ich kann es nur empfehlen !

Eneroths Plugin setzt nur voraus, dass man bei der Kamera "parallele Projektion" einstellt.
Antworten Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste