Austausch QGIS und Sketchup Pro
#1
Hallo zusammen,

ich scheitere gerade am Datenaustausch zwischen QGIS und Sketchup pro.

In QGIS habe ich eine Gebäude-Shapefile. Darin enthalten sind Gebäudeumrisse in Form von Polygonen.
(Openstreetmap-Shapefile von Geofabrik).
Nun dachte ich, exportiere ich die Gebäude ganz leicht als dxf und lade diese in Sketchup Pro ein.

Dies funktioniert jedoch gar nicht so einfach, wie ich mir das vorgestellt hatte.
Beim Import der dxf kommt folgende Meldung:
________________________________________________
Achtung:

Einige der importieren Geometrien sind sehr weit vom
Modellnullpunkt entfernt. Sollte es zu einer Instabilität bei
Ihrem SketchUp-Modell kommen, löschen Sie bitte die betreffende Geometrie
aus Ihrer .dwg/.dxf-Datei und führen Sie den Import erneut aus.

Importierte AutoCAD-Elemente:

    Layer:        1

Vereinfachte AutoCAD-Elemente:


Ignorierte AutoCAD-Elemente:

    Anonyme Blöcke:        1
    Zombies und Sonstige:    943
______________________________________________________

Danach kommt nur noch der Hinweis, dass der Import fehlgeschlagen ist.

Weiß jemand, was diese Hinweise bedeuten und wie ich den Import hinbekomme?

Anmerkung: habe bei den Importoptionen schon rumprobiert und mal "Zeichnungsnullpunkt beibehalten" angewählt und mal nicht, das Ergebniss bzw. der fehlschlag war derselbe.
Im Sketchup Modell habe ich auch schon probiert, vorher einen location-Snapshot einzufügen unter der Annahme, dass der import eventuell an der georeferenzierung der dxf scheitert, hat leider auch nicht geholfen.


Freue mich auf Hinweise und Hilfe!
Antworten Zitieren
#2
Hallo zusammen,

ich greife meine eigene Frage nochmal auf.

Letztes Mal konnte ich das problem leider nicht lösen, vllt. klappt es ja dieses mal.

Bei QGis habe ich eine shapefile mit einigen Gebäudeumrissen. Diese als dxf zu exportieren geht leider wieder gänzlich schief... einmal hat das Einladen in Sketchup nicht funktioniert (Fehlermeldung), einmal kam dabei eine ganz diffuse Darstellung zustande.

ich bin wie folgt vorgegangen:
Rechtsklick auf shape - speichern als - und dann gespeicht mit den Einstellungen wie sie im Screenshot zu sehen sind.


Die shapedatei ist im WeTransfer-Link zu finden: https://we.tl/XAk3t8ufQn

Vllt. kann mir jemand helfen?

Lieben Dank im voraus
Antworten Zitieren
#3
Ich konnte das Problem lösen...es lag am export bei QGis.

Als Koordinatensystem hatte ich WGS84, da hat der Export nicht richtig funktioniert.
Mit UTM hat es theoretisch geklappt, nur dass die Gebäudeumrisse (Polylinien in GIS) in SketchUP flächig dargestellt wurden (die vorherige Linie besteht hier nun 2 versetzten Linien mit Fläche).

Gelöst hab ich das ganze letztendlich nur eine Erweiterung, die das Einladen von shapefiles erlaubt. Aber auch hier hat nur die shp in UTM funktioniert, nicht die in WGS84.
Antworten Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste